Investigation on why database doesn’t start after successfully dropping a...
Few months ago, while performing storage migration I faced an interesting issue which could lead to potential downtime if I didn’t notice a hidden warning in the log file. The plan was to create a new...
View ArticlePRCR-1079 : Failed to start resource oranode1-vip. CRS-2680 Clean failed....
Last week we had a clusterware issue on one of the critical 3 node RAC environment. In the first node, network resource is restarted by ending up killing all sessions on that node abnormally. Oracle...
View ArticleHow to pass Oracle Database 12c: RAC and Grid Infrastructure Administration...
In this post I will talk about my journey on how to prepare and pass the 12c RAC and Grid Administration exam. About the exam Check the following link to get more information about the exam from...
View ArticleUsing deprecated ASM parameter might prevent your Cluster to start
Few days ago, I was testing some ASM parameters in my 3 nodes 12.2 Clusterware environment and used ASM_PREFERRED_READ_FAILURE_GROUPS parameter to see how I can force ASM to read specific failure...
View Article[INS-20802] Creating Container Database for Oracle Grid Infrastructure...
After dealing with root.sh script to configure 3 node clusterware environment I succeeded but ended up with the following error when post configuration OUI returned the following error and was unable...
View ArticlePerl related issues when running ./rootcrs.pl to deconfigure the node
Today while deconfiguring one failed node from the clusterware I faced some Perl related issues that blocked me to run ./rootcrs.pl command. After installing few required packages I was able to...
View ArticleInterim patch apply best practices in Oracle
Yestarday, after successfully applying an interim patch to the 3 node clusterware environment, I decided to share my experience with you. In this blog post, you can find some best practicec that I...
View ArticleORA-00304: requested INSTANCE_NUMBER is busy
There are a lot of explanation and different solutions for the error “ORA-00304: requested INSTANCE_NUMBER is busy”. But today, in my case while I was tyring to shutdown one of the cluster nodes, it...
View ArticleDefault listener “LISTENER” is not configured when running DBCA
When running dbca to create a new database you can get the following message: Default Listener “LISTENER” is not configured in Grid Infrastructure home. Use NetCA to configure Default Listener and...
View ArticleNode names are missing from ./runInstaller output
While installing Oracle Database after Oracle Grid Infrastructure installation, I was supposed to get the list of all nodes where I need to install Oracle Software (11gR2 – 11.2.0.4). But instead, I...
View ArticleStruggling with RAC Installation – ORA-15018: diskgroup cannot be created
I said it before. It was only once that I succeeded to install Oracle Clusterware without any issues and that was during OCM exam I didn’t hit any bug, I didn’t re-configured anything. The installation...
View ArticleGetting ORA-01105 during RAC db startup
Today, while starting RAC instances of 2 node RAC database (10gR2 on Linux), I got the following error in the first node: ORA-01105: mount is incompatible with mounts by other instances ORA-01677:...
View ArticleUsing odd number of disks for Voting disk
As you’ve already known, you should use odd number of disks for voting disk. A node must be able to strictly access more than half of the voting disks at any time. Let me show you how it works. I have...
View ArticleHow to troubleshoot CRSCTL REPLACE VOTEDISK error?
It took me some time to investigate why CRSCTL REPLACE VOTEDISK command is not working. [oracle@node1 ~]$ crsctl replace votedisk VDISK CRS-4264: The operation could not be validated CRS-4000: Command...
View ArticleCluster won’t start if diagnostic_dest folder is missing
One of the reason of why cluster won’t start is DIAGNOSTIC_DEST folder is missing. Here it is what I got today in of the nodes of the RAC environment: db-bash: crs_stat -t HA Resource Target State ———–...
View ArticleV$ASM_DISKGROUP displays information from the header of ASM disks
While playing with OCR recovery, suddenly I realized that V$ASM_DISKGROUP view gets information from the headers of the ASM disk files that are specified at *.ASM_DISKSTRING parameter. Here’s the...
View ArticleStep by Step Installing Oracle 12c RAC on VirtualBox – Video Tutorial
It’s 3.50 AM at San Francisco and I’m finalizing a new video tutorial that I have been creating for the users who will attend RAC Attack at Oracle Openworld 2013 (Ninja Operation). Tomorrow is the...
View ArticleI’m RACAttack Ninja!
I’m proud to announce that I’m one of the 10 RAC Attack Ninjas this year! If you’re attending OOW13, don’t forget to come and say “hi” to Ninjas. We’ll be at OTN Lounge in the lobby of Moscone South on...
View ArticleUser equivalence check failed for user “oracle”.
If you’ve installed and configured RAC environment, you should face “User equivalenece check” error during pre-requisite check There’re three common reasons for getting this error: - You didn’t...
View ArticleWaiting at “Performing remote operations” during RAC installation
Today, while installing RAC, the installation began to wait at “Performing remote operations” step. I’ve tried to check log files, but there was no information written Then I tried to trace the...
View Article